请选择 进入手机版 | 继续访问电脑版
加入学习
联系我们400-456-7892
电子邮箱services@dipreal.com

一个进程怎么取出它的不同窗口句柄呀?比如取出它的顶层句柄和子窗口句柄

[复制链接]
403800569 发表于 2016-7-3 10:21:40
1430 5
5金钱
如题:同一个进程怎么取出它的不同窗口句柄呀?比如取出它的顶层句柄和子窗口句柄

最佳答案

查看完整内容

窗口枚举句柄可以实现
cary110 发表于 2016-7-3 10:21:41
窗口枚举句柄可以实现
回复

使用道具 举报

 楼主| 403800569 发表于 2016-7-4 18:41:18
cary110 发表于 2016-7-3 21:44
窗口枚举句柄可以实现

我是想用进程来实现取所有句柄的功能。。。不过我找到了。。废了点事。。

.版本 2

重定义数组 (id组, 假, 0)
重定义数组 (句柄组, 假, 0)
进程_取ID数组 (“ssol.exe”, id组)
.计次循环首 (取数组成员数 (id组), a)
    加入成员 (句柄组, 进程_ID取窗口句柄 (id组 [a], “蜀山缥缈录”, “SSOLElementClient Web Window”))
    辅助延时 (50)
.计次循环尾 ()

这样搞定了

点评

先取到进程句柄(ssol.exe),然后再枚举找SSOLElementClient Web Window不是一样么  详情 回复 发表于 2016-7-6 23:05
回复

使用道具 举报

cary110 发表于 2016-7-6 23:05:12
403800569 发表于 2016-7-4 18:41
我是想用进程来实现取所有句柄的功能。。。不过我找到了。。废了点事。。

.版本 2

先取到进程句柄(ssol.exe),然后再枚举找SSOLElementClient Web Window不是一样么
回复

使用道具 举报

ouehrau 发表于 2017-9-18 18:52:03
不错,支持
回复

使用道具 举报

173107897 发表于 2017-11-17 08:53:53
我也看看怎么解决的,大神
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

发表新帖

推荐学习课程

在线客服
获取金钱  兑换金钱
充值交易币  我的推广


会员办理咨询:

论坛业务咨询:

Q群(426798682) 远航小伙伴交流群3


扫一扫加微信好友

QQ|Archiver|手机版|小黑屋|易编远航 ( 粤ICP备14079334号 [绑定手机] 充值积分 |

Powered by Discuz! X3.2  © 2001-2013 Comsenz Inc.  广州良师益友文化传播有限公司 ICP证:粤ICP备13026616号 增值电信业务经营许可证:粤B2-20140196

返回顶部 返回列表