关灯
请选择 进入手机版 | 继续访问电脑版
加入学习
开启左侧

一个进程怎么取出它的不同窗口句柄呀?比如取出它的顶层句柄和子窗口句柄

[复制链接]
403800569 发表于 2016-7-3 10:21:40 | 显示全部楼层 |阅读模式 打印 上一主题 下一主题
 
5金钱
如题:同一个进程怎么取出它的不同窗口句柄呀?比如取出它的顶层句柄和子窗口句柄

最佳答案

查看完整内容

窗口枚举句柄可以实现
 

精彩评论5

正序浏览
cary110 发表于 2016-7-3 10:21:41 | 显示全部楼层
 
窗口枚举句柄可以实现
回复

使用道具 举报

 
403800569 发表于 2016-7-4 18:41:18 | 显示全部楼层
 
cary110 发表于 2016-7-3 21:44
窗口枚举句柄可以实现

我是想用进程来实现取所有句柄的功能。。。不过我找到了。。废了点事。。

.版本 2

重定义数组 (id组, 假, 0)
重定义数组 (句柄组, 假, 0)
进程_取ID数组 (“ssol.exe”, id组)
.计次循环首 (取数组成员数 (id组), a)
    加入成员 (句柄组, 进程_ID取窗口句柄 (id组 [a], “蜀山缥缈录”, “SSOLElementClient Web Window”))
    辅助延时 (50)
.计次循环尾 ()

这样搞定了

点评

先取到进程句柄(ssol.exe),然后再枚举找SSOLElementClient Web Window不是一样么  详情 回复 发表于 2016-7-6 23:05
回复

使用道具 举报

 
 楼主| cary110 发表于 2016-7-6 23:05:12 | 显示全部楼层
 
403800569 发表于 2016-7-4 18:41
我是想用进程来实现取所有句柄的功能。。。不过我找到了。。废了点事。。

.版本 2

先取到进程句柄(ssol.exe),然后再枚举找SSOLElementClient Web Window不是一样么
回复

使用道具 举报

 
ouehrau 发表于 2017-9-18 18:52:03 | 显示全部楼层
 
不错,支持
回复

使用道具 举报

 
173107897 发表于 2017-11-17 08:53:53 | 显示全部楼层
 
我也看看怎么解决的,大神
回复

使用道具 举报

 
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

排行榜
作者专栏

联系我们:当前QQ有在线

联系QQ

联系微信

QQ客服服务:

905230496

QQ客服服务 905230496

QQ客服服务 905230496

QQ客服服务 905230496

Copyright   ©2015-2016  易编远航Powered by©Discuz!技术支持:迪恩网络    ( 粤ICP备14079334号